Skip to main content
← All vulnerabilities
CVE-2025-53689GHSA-44C3-38H8-9FH9

Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons

Published
Last modified
published
Not listed in CISA KEV
Critical (apache)
Fix
Fixed in 2.20.17, 2.22.1, 2.23.2-beta
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.jackrabbit:jackrabbit-spi-commons

    From 2.20.0 · fixed in 2.20.17; From 2.22.0 · fixed in 2.22.1; From 2.23.0-beta · fixed in 2.23.2-beta

  • org.apache.jackrabbit:jackrabbit-spi-commonsMaven

    From 2.20.0 · fixed in 2.20.17

  • org.apache.jackrabbit:jackrabbit-spi-commonsMaven

    From 2.22.0 · fixed in 2.22.1

  • org.apache.jackrabbit:jackrabbit-spi-commonsMaven

    From 2.23.0-beta · fixed in 2.23.2-beta

  • org.apache.jackrabbit:jackrabbit-coreMaven

    From 2.23.0-beta · fixed in 2.23.2-beta

  • org.apache.jackrabbit:jackrabbit-coreMaven

    From 2.20.0 · fixed in 2.20.17

  • org.apache.jackrabbit:jackrabbit-coreMaven

    From 2.22.0 · fixed in 2.22.1

References 1

lists.apache.org