Skip to main content
← All vulnerabilities
CVE-2025-53487

ApprovedRevs: Stored Cross-Site Scripting (XSS) via unsanitized system messages

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.39.13, 1.42.7, 1.43.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The ApprovedRevs extension for MediaWiki is vulnerable to stored XSS in multiple locations where system messages are inserted into raw HTML without proper escaping. Attackers can exploit this by injecting JavaScript payloads via the uselang=x-xss language override, which causes crafted message keys to be rendered unescaped. This issue affects Mediawiki - ApprovedRevs extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Wikimedia Foundation Mediawiki - ApprovedRevs extension

    From 1.39.x · fixed in 1.39.13; From 1.42.x · fixed in 1.42.7; From 1.43.x · fixed in 1.43.2

References 2

phabricator.wikimedia.org

gerrit.wikimedia.org