Skip to main content
← All vulnerabilities
CVE-2025-53484

SecurePoll: Multiple locations vulnerable to Cross-Site Scripting (XSS) via unescaped input

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.39.13, 1.42.7, 1.43.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

User-controlled inputs are improperly escaped in: • VotePage.php (poll option input) • ResultPage::getPagesTab() and getErrorsTab() (user-controllable page names) This allows attackers to inject JavaScript and compromise user sessions under certain conditions. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Wikimedia Foundation Mediawiki - SecurePoll extension

    From 1.39.x · fixed in 1.39.13; From 1.42.x · fixed in 1.42.7; From 1.43.x · fixed in 1.43.2

References 3

phabricator.wikimedia.org

gerrit.wikimedia.org