Skip to main content
← All vulnerabilities
CVE-2025-53479

CheckUser: Reflected Cross-Site Scripting (XSS) in Special:CheckUser via unsanitized internationalized message

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.42.7, 1.43.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

The CheckUser extension’s Special:CheckUser interface is vulnerable to reflected XSS via the rev-deleted-user message. This message is rendered without proper escaping, making it possible to inject JavaScript through the uselang=x-xss language override mechanism. This issue affects Mediawiki - CheckUser extension: from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Wikimedia Foundation Mediawiki - CheckUser extension

    From 1.42.x · fixed in 1.42.7; From 1.43.x · fixed in 1.43.2

References 2

phabricator.wikimedia.org

gerrit.wikimedia.org