Skip to main content
← All vulnerabilities
CVE-2025-5175PYSEC-2025-46GHSA-QPXX-2CWH-R5VH

erdogant pypickle pypickle.py save improper authorization

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • erdogant pypickle

    1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5

  • pypicklePyPI

    fixed in 2.0.0

  • pypicklePyPI

    fixed in 2.0.0

References 8

vuldb.com

GitHub · erdogant/pypickle