Skip to main content
← All vulnerabilities
CVE-2025-49557GHSA-8MQ8-C243-2335

Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.4-p15, 2.4.5-p14, 2.4.6-p12, 2.4.7-p7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be exploited by a low-privileged attacker to inject malicious scripts into vulnerable form fields. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field. Scope is changed.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p14

  • magento/community-editionPackagist

    fixed in 2.4.4-p15

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p14

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p12

  • magento/community-editionPackagist

    From 2.4.7-p1 · fixed in 2.4.7-p7

  • magento/community-editionPackagist

    2.4.8

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com