Skip to main content
← All vulnerabilities
CVE-2025-49555GHSA-5777-JJ7P-MPQW

Adobe Commerce | Cross-Site Request Forgery (CSRF) (CWE-352)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that could result in privilege escalation. A high-privileged attacker could trick a victim into executing unintended actions on a web application where the victim is authenticated, potentially allowing unauthorized access or modification of sensitive data. Exploitation of this issue requires user interaction in that a victim must visit a malicious website or click on a crafted link. Scope is changed.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p14

  • magento/project-community-editionPackagist

    through 2.0.2

  • magento/community-editionPackagist

    From 2.4.9-alpha1 · fixed in 2.4.9-alpha2

  • magento/community-editionPackagist

    From 2.4.8-beta1 · fixed in 2.4.8-p2

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p7

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p12

  • magento/community-editionPackagist

    fixed in 2.4.5-p14

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.8

References 1

helpx.adobe.com