Skip to main content
← All vulnerabilities
CVE-2025-49147GHSA-PGVC-6H2P-Q4F6

Umbraco.Cms Vulnerable to Disclosure of Configured Password Requirements

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.8.111, 13.9.2, 10.8.11
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • umbraco Umbraco-CMS

    From 10.0.0 · fixed in 10.8.111; From 13.0.0 · fixed in 13.9.2

  • Umbraco.CmsNuGet

    From 10.0.0 · fixed in 10.8.11

  • Umbraco.CmsNuGet

    From 13.0.0 · fixed in 13.9.2

References 3

GitHub · umbraco/Umbraco-CMS