Skip to main content
← All vulnerabilities
CVE-2025-48924GHSA-J288-Q9X7-2F5V

Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 3.18.0
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • commons-lang:commons-lang

    From 2.0 · through 2.6

  • org.apache.commons:commons-lang3

    From 3.0 · fixed in 3.18.0

  • org.apache.commons:commons-lang3Maven

    From 3.0 · fixed in 3.18.0

  • commons-lang:commons-langMaven

    From 2.0 · through 2.6

References 2

lists.apache.org

GitHub · njawalkar/apache-commons-lang2