Skip to main content
← All vulnerabilities
CVE-2025-48371GHSA-C72G-53HW-82Q7GO-2025-3707

OpenFGA Authorization Bypass

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.13
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • openfga openfga

    From 1.8.0 · fixed in 1.8.13

  • github.com/openfga/openfgaGo

    From 1.8.0 · fixed in 1.8.13

References 2

GitHub · openfga/openfga